Jump to content
www.BoXa.net
Sign in to follow this  
JohnSyn

Zunsport grills

Recommended Posts

Struggling to fit one of the grills, I've fitted them to two previous cars without issues.

Any tips?

Share this post


Link to post
Share on other sites

Not got a GTS (well the back lights Are gts😁) you havre to be firm with them mate.

Edited by fat haggis

Share this post


Link to post
Share on other sites

I found when I fitted mine (S not GTS) that sometimes you need to adjust the curve of them slightly to get them to fit properly. So offer them up in place, see where they're not quite fitting flush and then gently bend them by hand before trying again - usually only a few millimetres. I've seen some people online complaining about the need to do this, but to me it's inevitable with something that is basically handmade to a template. Having said that, I believe there have been occasions when they simply don't fit correctly. So if they look as if they're never going to fit into the correct place, I would suggest taking some photos with them as close as you can get them, to show where they overlap (or whatever), and emailing Zunsport about it - they seem pretty good at rectifying issues like this.

Share this post


Link to post
Share on other sites
4 hours ago, fat haggis said:

Not got a GTS (well the back lights Are gts😁) you havre to be firm with them mate.

Thanks. As say I have fitted them before but for some reason the centre one wont go in.

Share this post


Link to post
Share on other sites
4 hours ago, Jon61 said:

I found when I fitted mine (S not GTS) that sometimes you need to adjust the curve of them slightly to get them to fit properly. So offer them up in place, see where they're not quite fitting flush and then gently bend them by hand before trying again - usually only a few millimetres. I've seen some people online complaining about the need to do this, but to me it's inevitable with something that is basically handmade to a template. Having said that, I believe there have been occasions when they simply don't fit correctly. So if they look as if they're never going to fit into the correct place, I would suggest taking some photos with them as close as you can get them, to show where they overlap (or whatever), and emailing Zunsport about it - they seem pretty good at rectifying issues like this.

Thanks Jon. I have tried 'adjusting' them but stopped as it was getting dark and cold and I was not in the best of moods! Going to try again next weekend hopefully when I've plenty of time!

Share this post


Link to post
Share on other sites

This may help John?

 

Share this post


Link to post
Share on other sites
5 minutes ago, MIkeyv60 said:

This may help John?

 

Yeah. That’s  similar to when i did my 987. You have to jab the ‘hooks’ with a screwdriver

Share this post


Link to post
Share on other sites

Fitted one to the front of the MX and that took some pushing and more force than i was happy with, works well though now it's in place.

Share this post


Link to post
Share on other sites
8 hours ago, Gutley said:

Yeah. That’s  similar to when i did my 987. You have to jab the ‘hooks’ with a screwdriver

Yes that's what I did with the other cars when I've fitted them. However on this car I just cannot seem to get it to go. I think four hands would help!

Share this post


Link to post
Share on other sites
4 minutes ago, That986 said:

Fitted one to the front of the MX and that took some pushing and more force than i was happy with, works well though now it's in place.

Tried the brute force method but didn't seem to work, although my brute force may be a little jaded now!

Share this post


Link to post
Share on other sites
8 hours ago, MIkeyv60 said:

This may help John?

 

Thanks Mike, yes I watched that avidly! When I try to fix mine when you come to push in the grill, so you only have to bend the clip over, the other end of the grill moves and you cannot position the end you are trying to secure. I was trying to do it on the quick Saturday evening as it was getting dark. Couldn't try yesterday, family duties, so will try again next Saturday!

Share this post


Link to post
Share on other sites
3 hours ago, JohnSyn said:

Tried the brute force method but didn't seem to work, although my brute force may be a little jaded now!

Yup, i had to resort to 2 screwdrivers in the end. One levering the grille, one pushing the tab. 

Share this post


Link to post
Share on other sites
10 hours ago, That986 said:

Yup, i had to resort to 2 screwdrivers in the end. One levering the grille, one pushing the tab. 

Ah...hadn't thought of using two screwdrivers! This may work!

Share this post


Link to post
Share on other sites
15 hours ago, JohnSyn said:

Ah...hadn't thought of using two screwdrivers! This may work!

Neither did i until my thumb started to hurt from pushing, lol. 

Share this post


Link to post
Share on other sites
55 minutes ago, That986 said:

Neither did i until my thumb started to hurt from pushing, lol. 

It worked too! Thanks. Grills fitted!

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, JohnSyn said:

It worked too! Thanks. Grills fitted!

No worries, glad it worked.

Share this post


Link to post
Share on other sites

I’ve had the front outer grilles since October last year and just got around to fitting them.

I say fitting them but no matter how much manipulation and brute force I cannot get the hook to clip behind the parking sensor. Chucked them back in the box and emailed Zunsport...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...